1. Computing

Installing Gosu

By

 Installing Gosu

While Gosu does require native compilation, the developers thankfully require pre-compiled packages for all platforms. On Windows, Linux and OS X, Gosu can be installed with a single gem command.

You will, of course, need to install Ruby first. At the time of this writing, Gosu works fine with Ruby 1.8.6, 1.8.7 and 1.9.2, so any of these versions will work. Once you've installed Ruby, issue the following gem install command.


$ gem install gosu

This article is part of a series. Read more articles about Rapid Game Prototyping in Ruby

  1. About.com
  2. Computing
  3. Ruby
  4. Tutorials
  5. Rapid Game Prototyping with Gosu
  6. Installing Gosu>

©2014 About.com. All rights reserved.