1. Technology

Articles related to ruby 1.8.7

Using JSON: The JSON Gem - Ruby
On Ruby 1.8.7, you'll need to install a gem. However, in Ruby 1.9.2, the json gem is bundled with the core Ruby distribution. So, if you're using 1.9.2, you're ...
http://ruby.about.com/od/tasks/a/The-Json-Gem.htm
Indexing Strings - Ruby - About.com
However, before reading this article, you'll need to know your Ruby version. ... ruby --version ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-darwin11.0.0].
http://ruby.about.com/od/strings/a/Indexing-Strings.htm
Methods - Ruby - About.com
It's usually the last argument in the list (and must be on Ruby 1.8.7 and before) will appear as an array of the arguments it soaked up within the method.
http://ruby.about.com/od/oo/ss/methods.htm
Using RVM Gemsets in Ruby - Easy Tutorial - About.com
I'll be switching to 1.8.7. Next, just use the rvm gemset create command, along with a descriptive name for the gemset. I'll be creating a gemset for both Rails 2 ...
http://ruby.about.com/od/rubyversionmanager/a/Using-Rvm-Gemsets.htm
Splitting Strings in Ruby - the String#split Method - About.com
Ruby is not real big on "special variables" that you might find in languages like ... over the string, and was used in pre-1.9.x and pre-1.8.7 (which backported a ...
http://ruby.about.com/od/strings/a/Splitting-Strings.htm
Iterating Over Strings - Ruby - About.com
... in a string. Unicode complicates this matter, but Ruby makes it simple. ... You can turn on Unicode in 1.8.7 by assigning "u" to $KCODE. If you do that or fire up  ...
http://ruby.about.com/od/strings/ss/Siterating-Over-String.htm
Installing Gosu - Ruby - About.com
You will, of course, need to install Ruby first. At the time of this writing, Gosu works fine with Ruby 1.8.6, 1.8.7 and 1.9.2, so any of these versions will work.
http://ruby.about.com/od/gosugme/ss/Installing-Gosu.htm
Listing Known Rubies - Ruby - About.com
(ruby-)1.8.7-head (ruby-)1.9.1(-p243) (ruby-)1.9.1(-p376) ... The format of these names is important. You'll notice that portions of these names are in parentheses  ...
http://ruby.about.com/od/rubyversionmanager/a/rvminfo.htm
Installing Ruby on Snow Leopard with RVM - About.com
OS X 10.6 "Snow Leopard" comes with both Ruby 1.8.7 and Ruby on Rails ... want to install your own with RVM, access to Ruby 1.9.2 being the most obvious.
http://ruby.about.com/od/rubyversionmanager/ss/Installing-Ruby-On-Snow-Leopard-With-Rvm.htm
Installing Ruby on Rails on OS X - About.com
As mentioned above, Apple does include Ruby with OS X, but OS X Lion (OS X version 10.7.3, the current version as of this article) comes with Ruby 1.8.7.
http://ruby.about.com/od/rails3tutorial/ss/Installing-Ruby-On-Rails-On-Os-X.htm
1  |  2  |  3      Next

©2014 About.com. All rights reserved.